MySQL5に移行

Pocket

WordPressは2.9からは、MySQLは4.1.2以上でないと使えません。MySQL5ならばOKです。
ところが私の使っているMySQLは4.1.2未満だったのでアップグレードできませんでした。
MySQL4から5にするためにはデータベースの移行が必要なので躊躇していました。またPHPとの相性の問題もあるかもしれず、エラーが出たら面倒だと思っていました。

今般、思い切ってMySQL5に移行しました。
私が使っているレンタルサーバでは、まずMySQL4のデータベースからMySQL5の試用のデータベースにコピーされます。
この間、新旧のデータベースは使えません。つまり、このコピーの間はデータベースを使うウェブページにはエラーが表示されるのです。「只今、メンテナンス中」などという表示をするのが鉄則ですが、面倒なので、放置。
しかし、何時間もかかると思っていた、このコピーはわずか1分ほどで終了。

早速、phpMyAdminで新データベースの中身を覗いてみました。問題なくコピーされているようです。
次に、このブログの接続先データベースを書き換えてみました。そして適当なコメントを入れてみたところ、これも無事、新データベースに反映されました。
その他の自作のウェブページも試してみましたが問題なさそうです。

そこで試用ではなく本番で使用するように設定します。この切替は数秒。旧データベースが削除されます。
今夜は徹夜も覚悟していましたが、あまりに簡単なので拍子抜けしました。

WordPressも無事、2.9.1にアップグレードできました。

WordPress | 日本語 » WordPress 2.9.1 日本語版リリースのお知らせ

[ 2010年1月23日 | カテゴリー: WordPress | タグ: , ]

« | »

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

送信してください。


タグ

カテゴリー

最近の投稿

最近のコメント

固定ページ

アーカイブ

stabucky

写真

メタ情報