「Segmentation fault: 11」のときに試した方法

Pocket

Pythonのmatplotlibを使うツールを使っているのですが、急にエラーが出るようになりました。
「Segmentation fault: 11」というエラーです。
「show()」の部分で止まります。

最近、変えたことといえば、macOS Big Surにバージョンアップしたこと。
次のようにするとインストールされているライブラリとそのバージョンが分かります。

$ pip list

matplotlibはバージョンが3.0.3でした。

試しにアンインストールして、改めてインストールしてみます。

$ pip uninstall matplotlib
$ pip install matplotlib

今度はバージョンが3.3.3になりました。
これで実行したところ、正しく処理できました。

[ 2020年11月19日 | カテゴリー: デジタル | タグ: , , ]

« |

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

送信してください。


タグ

カテゴリー

最近の投稿

最近のコメント

固定ページ

アーカイブ

stabucky

写真

メタ情報